EagleCAD

From DiLab

Jump to: navigation, search

Eagle CAD ir programmatūra elektronisko shēmu ievadam un spiesto plašu projektēšanai.

  • Mazas plates un nelielus projektiņus, piemēram, robotiņiem, var veidot par brīvu.
  • Lielāku plašu ar vairākiem slāņiem projektēšanai nepieciešama īpaša licence.

Pamācības

Internetā atrodamas vairākas pamācības gan teksta gan video formātos.


Videoklipus nepacietīgākiem iesaku atspēlēt lielākā ātrumā, piemēram, ar mplayer un '[', ']' pogām. Video pamācības:

Shēmu ievads

Darbs ar grupām

Lai atzīmētu vairākus shēmas elementus un, piemēram, tos pārvietotu, var darīt tā:

  1. izvēlamies Grupas ikonu
  2. atzīmējam elementus velkot peli
  3. ar peles labo pogu izsaucam menu, kurā atzīmējam "Move group"
  4. pārvietojam grupu

Tas pats, manuprāt, ērtāk:

  1. Atzīmējam Move ikonu
  2. Atzīmējam Grupas ikonu
  3. atzīmējam vajadzīgos elementus
  4. Ctrl + Right-click un pārvietojam grupu

Līdzīgi var veikt arī citas operācijas ar grupām

Komponenšu pievienošana


Lietojam komandas: atslēdzam visas bibliotēkas, tad pieslēdzam, piemēram, SparkFun un rlc bibliotēkas

use -*
use SparkFun*
use rlc

Pieslēdzam visas bibliotēkas

use *

Kopēt starp shēmām

Šī iespēja ir sākot no EagleCAD 6.versijas. Būs jaatver divas EagleCAD instances.

  1. Atveram shēmu SOURCE no kuras kopēt
  2. Atveram mērķa shēmu TARGET jaunā EagleCAD instancē
  3. SOURCE: atzīmējam detaļas (Group) un izvēlamies Copy
  4. TARGET: izvēlamies Paste

No shēmas uz PCB

Elementārākais veids ir nospiest "Board" ikonu. Ja PCB fails neeksistē, tas tiks radīts.

Pēc shēmas izmaiņas

Ja shēmā kaut kas izmainās, PCB dizainu vajadzētu attiecīgi papildināt, automātiski. To var darīt ar "ECB" ikonu - Electric Rule Check - shēmas redaktorā. Pie reizes varbūt atradīsies arī nesavienoti vadi vai citi brīnumi - paskatieties "Warnings", ja tādi ir.

Ja viss kārtībā, status bar-ā rādīs "board and schematic are consistent".

PCB rediģēšana

Elementu rotēšana

  • Paņem elementu un Right-Click

Komponenšu novietošana otrā puse platei

  • Lieto "Mirror" opciju lai novietotu komponentes otrā pusē platei.
  • Vadu pārcelšanai uz otru pusi klikšņina uz vietu kur būs VIA, tad maina "Layer". Priekš tam man ir uzstādīti "shortcuts": Ctrl+1 = Top layer, Crtl+2 = Bottom layer, utt.

Snap to grid

  • Ctrl + "Move" lai pārliktu elementa koordinātes uz izvēlēto režģi - izlīdzināšanai.
  • Ctrl + Alt + "Move" lai pārliktu elementa koordinātes uz izvēlēto alternatīvo režģi.

Poligoni

  • Aizpildīt poligonu: RATSNEST
  • Nodzēst pildījumu, lai labāka redzamība: RIPUP (jātrāpa uz poligona ārējās malas)
  • Izslēgt automātisku aizpildīšanu:
    • Menu->Options->Set->Misc->Ratsnets processes polygons
    • vai ar komandu SET POLYGON_RATSNEST OFF;

Atsauces: Cadsoft Eagle tips and tricks (Dangerous prototypes)

VIAs, barjeras

Ja mums ir "ground plane" divos līmeņos, nereti vērts tos savienot ar papildus VIA, reizēm veidojot pat barjeru (picket fence) no VIA elementiem. Lai to paveiktu:

  • Izveido jaunu VIA
  • Ar NAME piešķir šai VIA vārdu, piemēram GND.
  • Ar Copy veido papildus VIAs.

Nav ieteicams lietot grupas kopēšanu, jo tas piešķirs jaunajām VIA jaunu vārdu.

Atsauces: HOW-TO: STITCHING VIAS IN EAGLE

VIAs, Soldermask

Lai VIAs netiktu atstatas bez soldermask - plikas, tad var izmainīt urbuma minimalo diametru pie DRC -> Masks -> Limit. Piemeram, ja tur ieraksta 24mil, tad visas VIAs ar urbubu kas mazaks par 24mil tiks "aizkrāsotas".

NAME & VALUE

Elementu vārdus un vērtības iespējams likt kā Teksta objektus ar attiecīgām vērtībām >NAME un >VALUE uz attiecīgiem slāņiem: Layer 25 (tName) un Layer 27 (tValue).

  • Vēlams ieslegt vektoru fontus: Menu -> Options -> User Interface... -> Always vector font & Persistent in this drawing
  • Ieteicamie izmēri (properties):
    • Name: Size = 0.8128, Ratio = 18%
    • Value: Size = 0.4064, Ratio = 10%

Atsauces: KTOWN's Ultimate Creating Parts in Eagle Tutorial (Adafruit)

Marķieris

Marķieri var nolikt jebkurā vietā un redzēt relatīvās koordinātes no marķiera. Komandas:

  • Koordinātē x, y
MARK (C x y);
  • Peles koordinātē
MARK (@);
  • Atgriezt marķieri uz 0,0
MARK;

Bibliotēkas

Tagad Sparkfun bibliotēkas pieejamas no Github:

Agrāk SparkFun bibliotēka bija pieejama bibliotēka ar vairumu jau izstrādātiem šabloniem dažādām populārām komponentēm un moduļiem.

Kā kopēt "device" simbolu

No projekta pārlūka zem bibliotekām atrod vajadzīgo simbolu, tad right-click un izvēlas Copy to library.

Īsceļi (Shorcuts)

EagleCad filozofija ir tāda, ka iespējams ievadīt komandas no komandu rindas tās rakstot. Tāpēc nevar ieslēgt, piemēram, Move režīmu tam piekārtojot M taustiņu. Toties var lietot Alt/Ctrl/Cmd + burts/cipars kombinācijas, un tās saglabāt savā (.eaglerc) profilā.

Shēmas un PCB redaktoriem ir katram savs "shortcut" komplekts. Ja vienā definē, piemēram, Alt+M -> Move, tad otrā tas pats no sevis neparādīsies, un arī ir jādefinē.

Shortcut var izvēlēties no Menu->Options->Assign... Var arī rakstīt pa tiešo .eaglerc failā, bet jāuzmanās, lai Eagle nepārraksta tam pāri savu informāciju. Var izveidot arī savu skriptu (*.scr), ko ielādē Eagle ar File->Script.

Seko manas iecienītākās taustiņu kombinācijas, ko esmu iestādījis savā Eagle konfigurācijā. Ņemot vērā, ka gadās lietot Eagle gan no Linux/PC gan Mac datoriem, priekšroku dodu Alt+ kombinācijām, jo Ctrl un CMD taustiņu ideoloģija un izvietojums nedaudz atšķiras uz abām platformām.

Komanda Tausiņi, Piezīmes
Assign Ctrl+A
Move
  • Alt+M
  • Alt+Z (ērtāk ar kreiso roku)
Group Alt+G
Info Alt+I
Junction
  • Alt+J
  • Alt+X (ērtāk ar kreiso roku)
Label Alt+L
Name Alt+N
Value Alt+V
Wire Alt+W
Delete Alt+D
Personal tools